How to change AdSense ad code support for SSL

google-adsense-logo
google-adsense-logo

If your site can be accessed over HTTPS, then you may need to update older versions of AdSense ad code to avoid the AdSense script being blocked as mixed content. If your AdSense ad code has a script starting with “http://”, then you should update it to “https://” instead:


The HTTPS version of the ad code is also safe for HTTP pages; you don’t need to serve two different versions.

The SSL-compatible ad code also works on HTTP sites and doesn’t change how ads are served on these sites.

How to Upgrade PHP version 5.4 to 5.6 on CentOS/RHEL 6/7

For CentOS/RHEL 7:

# rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm
# rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm
For CentOS/RHEL 6:

# rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
For CentOS/RHEL 5:

# rpm -Uvh http://mirror.webtatic.com/yum/el5/latest.rpm
After installing Webtatic yum repository, you have to remove the old version of php-common package. It will also delete it dependencies packages.
# yum remove php-common

yum install -y php56w php56w-opcache php56w-xml php56w-mcrypt php56w-gd php56w-devel php56w-mysql php56w-intl php56w-mbstring php56w-fpm php56w-common php56w-soap